Internet Over OSPF Mikrotik

Telah lama bermain di Bridging dan VLAN akhirnya coba setting OSPF sederhana MikroTik. Cari – cari dan modifikasi untuk membuat internet via Routing OSPF , OSPF yang digunakan konsep area dengan routing domain OSPF. 

Contoh jaringan diatas terdiri dari 3 router yang terhubung dengan network 172.16.10.0/24 dan masing-masing router mempunyai 1 jaringan LAN. Serta mempunyai 1 gateway ke internet pada MikroTik R1. Contoh setting OSPF di MikroTik ini di konfigurasi dengan IP address :

[admin@MikroTik-R1]/ip address add address=172.16.10.1/30 interface=ether1
[admin@MikroTik-R1]/ip address add address=172.16.10.5/30 interface=ether2
[admin@MikroTik-R1]/ip address add address=192.168.11.1/24 interface=ether3
[admin@MikroTik-R1]/ip address add address=222.22.0.2/30 interface=ether4

[admin@MikroTik-R2]/ip address add address=172.16.10.6/30 interface=ether1
[admin@MikroTik-R2]/ip address add address=172.16.10.9/30 interface=ether2
[admin@MikroTik-R2]/ip address add address=192.168.22.1/30 interface=ether3

[admin@MikroTik-R3]/ip address add address=172.16.10.2 /30 interface=ether1
[admin@MikroTik-R3]/ip address add address=172.16.10.10/30 interface=ether2
[admin@MikroTik-R3]/ip address add address=192.168.33.0/24 interface=ether3

Setingan dasar konfigurasi OSPF di MikroTik :

  1. Mengaktifkan OSPF instance
  2. Konfigurasi OSPF area dan network 

    1. Mengaktifkan OSPF instance :


    /Routing OSPF

    Kita akan menggunakan Default instance. Dalam default instance router-id 0.0.0.0, dalam arti router akan menggunakan salah satu IP address sebagai router-id. Setiap router OSPF menggunakan ID untuk saling mengenal ID juga digunakan sebagai penunjuk dari mana sebuah LSA berasal. Jika tidak digunakan, maka router OSPF akan mengambil IP Address dari salah satu interfacenya yang aktif untuk dijadikan Router ID dan bila terdapat beberapa IP Address maka IP Address tertinggi yang dipilih. 
    Di rekomendasikan untuk membuat Loopback IP Address sebagai router-id. Loopback IP Address adalah virtual, IP bisa digunakan untuk identitas router dalam jaringan. Interface Loopback merupakan interface yang tidak pernah berada dalam posisi “down”, sehingga IP Address pada interface ini cocok dijadikan Router ID.  Konfigurasi Loopback Interface :

    [admin@MikroTik-R1] /interface bridge add name=loopback
    [admin@MikroTik-R1] /ip address add address=10.11.12.1/32 interface=loopback
    [admin@MikroTik-R1] /routing ospf instance set 0 router-id=10.11.12.1 distribute-default=always-as-type-1

    Karena R1 mempunyai jalur gateway ke internet jadi ditambahkan option “distribute-default=always-as-type-1”.

    OSPF juga dapat digunakan untuk menyebarkan (redistribute) konfigurasi statik routing yang ada pada sebuah router. Sehingga entry static routing tersebut akan diketahui oleh router OSPF lainnya. Redistribute ini umumnya diterapkan pada router OSPF yang terhubung ke jaringan luar (outside network), misalnya pada R1 berfungsi sebagai gateway ke Internet.

    [admin@MikroTik-R2] /interface bridge add name=loopback
    [admin@MikroTik-R2] /ip address add address=10.11.12.2/32 interface=loopback
    [admin@MikroTik-R2] /routing ospf instance set 0 router-id=10.11.12.2

    [admin@MikroTik-R3] /interface bridge add name=loopback
    [admin@MikroTik-R3] /ip address add address=10.11.12.3/32 interface=loopback
    [admin@MikroTik-R3] /routing ospf instance set 0 router-id=10.11.12.3

    2. Konfigurasi OSPF Area

    Langkah berikutnya adalah untuk mengkonfigurasi OSPF Area. Backbone Area secara default sudah ada di MikroTik. ID Backbone Area adalah 0.0.0.0 (selalu zero/nol).
    Karena ada beberapa network menggunakan IP 172.16.10.0/30, 172.16.10.4/30, 172.16.10.8/30, di contoh ini menggunakan network 172.16.10.0/24. agar tidak setting satu persatu.

    Di R1 :

    [admin@MikroTik-R1] /routing ospf network add network=192.168.11.1/24 area=backbone
    [admin@MikroTik-R1] /routing ospf network add network=222.22.0.2/30 area=backbone
    [admin@MikroTik-R1] /routing ospf network add network=172.16.10.0/24 area=backbone

    Di R2 :

    [admin@MikroTik-R2] /routing ospf network add network=192.168.22.1/24 area=backbone
    [admin@MikroTik-R2] /routing ospf network add network=172.16.10.0/24 area=backbone

    Di R3 :

    [admin@MikroTik-R3] /routing ospf network add network=192.168.33.0/24 area=backbone
    [admin@MikroTik-R3] /routing ospf network add network=172.16.10.0/24 area=backbone

    Pastikan Settingan OSPF di MikroTik Anda berfungsi dengan baik. Cek OSPF Anda, berstatus DR (Designated Router) dan BDR (Backup Designated Router), yang bertugas sebagai cadangan dari DR). Router yang memiliki Router ID tertinggi akan menjadi DR, kemudian disusul oleh Router ID terendah berikutnya yang akan menjadi BDR.

    [admin@MikroTik-R1] /routing ospf neighbor pr

    Pastikan OSPF di masing-masing router (DAo)

    [admin@MikroTik-R1] /ip route pr

    Setelah ini baru akan mengembangkan MPLS …. Semangat …

    Add a Comment

    Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

    This site uses Akismet to reduce spam. Learn how your comment data is processed.

    Open chat