Mikrotik Layer7 Youtube

Kadangkala kita kelebihan bandwith internet, dan youtube sebagian tidak mengenakan FUP untuk youtube cache na, jadi alangkah baiknya kita berikan prioritas untuk youtube bagi sharing internetnya dengan bw yang kecil,

 

oke gas… sekarang ane mau sharing untuk membuat prioritas youtube sesuai dengan kebutuhan, yang jelas prioritinya dibuat pcq untuk berbagi rata bandwith youtubenya.
Ada beberapa script yang ane tanya sama mbah dan ini sangat baik untuk menangkap youtube dengan layer7 nya mikrotik.
yang pertama ini sudah di coba dan oke
  • layer 7 youtube

 

/ip firewall layer7-protocol
add name=youtube regexp=”r[0-9]+—[a-z]+-+[a-z0-9-]+.googlevideo.com”
/ip firewall mangle
add action=mark-connection chain=prerouting layer7-protocol=youtube new-connection-mark=ytvid_conn src-address=ip-prioriti-youtube
add action=mark-packet chain=prerouting connection-mark=ytvid_conn new-packet-mark=ytvid_pkt passthrough=no
/queue simple
add max-limit=128k/256k name=Youtube packet-marks=ytvid_pkt target=ip-prioriti-youtube
  • berikut kumpulan layer7 untuk video :

 

  • streaming video

 

^.*(.*cdn[d]{2,}.com|edge.telin.swiftserve.com|videos5.mediacorp.sg|cdn.yimg.com.*ts|akamaihd.net|rackspacecloud.com|stream.telin.swiftserve.com|nsimg.net|reftag|fbcdn.net/hvideo.*|pdlvimeocdn-a.akamaihd.net|vimeocdn.com|googlevideo.com|dailymotion.com|metacafe.com|videos2.yjcontentdelivery.com|vt.tumblr.com|mccont.com|edge.liveleak.com|.*xvideos.com|phncdn.com|rncdn3.com|cloudfront.net|bangyoulater.com|wasumdo.sextgem.com|steamstatic.com|.*_all/.*ts).*$
  • video content

 

/ip firewall layer7-protocol
add name=http-video regexp=”http/(0.9|1.0|1.1)[x09-x0d ][1-5][0-9][0-9][x09-x0d -~]*(content-type: video)”
  • streaming video youtube

 

/ip firewall layer7-protocol
add name=video_stream regexp=”(get_video\?|videoplayback\?|videodownload\\?|\.flv\?|\.fid\?)”

Tinggalkan Komentar

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

This site uses Akismet to reduce spam. Learn how your comment data is processed.